Migrar de PHP4 a PHP5

Dado que ya tiene fecha para el funeral nuestro querido PHP4 me decidí a migrar el servidor a PHP5. La instalación se hizo en un par de minutos gracias a la colaboración de Debian y Aptitude. PHP5 viene con el soporte para MySQL desactivado así que había que activarlo en php.ini

Llegaba el momento de comprobar el resultado, todas las webs iban bien menos una (siempre tiene que haber alguien para joder la marrana), daba problemas con los Warnings. Según parece PHP4 viene con estos avisos desactivados mientras que PHP5 si los muestra. La solución era fácil, editar el php.ini.

Después de esto y algunos pequeños cambios más en el archivo de configuración (a gusto del consumidor) la migración ha sido un éxito, supongo que en parte porque casi todas las webs se basan en scripts precocinados y preparados para PHP5 aunque el único problema seria con los TAGS de PHP.

Hosting web con soporte PHP5

3 comments

  • name

    No fastidies. Si tienes problemas con los “warnings”, ignorarlos es como dejar el polvo debajo de la alfombra. Este tipo de avisos no se deben ignorar.

    Por cierto, en los feeds aparecen “warnings” de “división por cero”.

  • Friki

    Estoy mirando lo del error del RSS pero lo da el plugin de Text Link Ads así que supongo que sera fallo suyo.

    Si un script no esta programado por mi no voy a preocuparme de los Warnings, ya lo hará su autor o el administrador de la web.

  • Diego

    Friky, gracias por la informacion, me es muy util, ya que hice un servicio en PHP5 que trabaja con una placa Exemys con comunicacion IP, yo tengo en el servicio con el try resuelto el tema si se cae la conexion, osea que lo resuelvo, sin embargo, el php5 me tira warning a patadas…, ahora con tu explicacion puedo quitarlos, como te dije tu info me fue muy adecuada, gracias

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *